MSI Endanwender-Forum

Allgemeines Forum => Rund um Software => Linux & Co => Thema gestartet von: supergamer am 29. Mai 2007, 12:36:21

Titel: Ubuntu 7.04 - 3D Probleme
Beitrag von: supergamer am 29. Mai 2007, 12:36:21
Hey.

Ich hab mich nochmal an Linux drangehaengt und diesmal mit Ubuntu.

Bin sehr sehr zufrieden denn das leauft einwandfrei und auh Programme sind
sehr schnell installiert und konfiguriert. Bei den letzten versuchen auf
Linux umzusteigen scheiterte es an den unterschiedlichsten dingen aber nun
lauft alles 1A ausser ...

Der altgeliebte ATI Treiber. (Anleitung von hier (http://wiki.cchtml.com/index.php/Ubuntu_Feisty_Installation_Guide))
Ich habe den Treiber aus dem \"Install the Driver the Ubuntu Way\" part installiert
und mit diesem leuft z.B. Beryl (3D Desktop) sehr gut aber wenn ich ein beliebiges
3D Spiel Starte sieht dies einfach nur verbuggt aus und man kann teilweise nichts
erkennen. Desweiteren kann man auch mit diesem Treiber scheinbar nicht auf einen
externen BIldschirm schalten.

Nun gut dann hab ich mal den andren Weg probiert \"Install the 8.36.5 Driver Manually\"
Bei diesem geht die Standartoberfleache Metacity sehr gut aber 3D Spiele sowie
der fglrx/3D Desktop geht nicht bzw die oberfleache ist nicht zu erkennen da alles
bunt ist und man auch Icons nicht erkennt.

Nun da dieses System nun sogut leauft und ich alles Probiert hab um noch dieses kleine
Treiberproblem zu loesen und nichts klappt wende ich mich an euch.

Kleine Anmerkung: Hatte vorher Ubuntu Ultimate 1.2 (6.10) und dies lief 3D Desktop und
3D Spiel sehr gut und fluesig.

Edit : Habe gelesen das es bei manchen Ati Radeon x1600 karten eine Problemloesung
         durch senken des Grafikspeichers der zur verfuegung steht aber da ich eine Laptop hab
         ist Biosmaessig nichts zu machen.


Hoffe mir kann jemand helfen.

Mfg Supergamer
Titel: Ubuntu 7.04 - 3D Probleme
Beitrag von: supergamer am 31. Mai 2007, 16:00:13
Ich habe nochmal ein altes Ubuntu draufgeschmissen und ich muss feststellen
das die Versionen 6.06 und 6.10 sehr gut laufen und dieses Problem nicht zeigen.

Trotzdem brauch ich eine loesung fuer Feisty und ich hoffe jemand kann mir helfen ;)


Mfg Supergamer
Titel: Ubuntu 7.04 - 3D Probleme
Beitrag von: ein Nobody am 31. Mai 2007, 17:06:44
Jo hi du Sorgenkind

Ja wie soll ich es dir erklären, wenn du keinerlei FAQs oder Bücher liest ?  :rolleyes:

Also den Treiber solltest du schon installieren können, danach mußt du in deiner xorg.conf:

/etc/X11/xorg.conf  

die sieht Standartmäßig so aus:

Section \"Device\"
   Identifier   \"Standardgrafikkarte\"
   Driver      \"vesa\"
   BusID      \"PCI:1:0:0\"
EndSection

noch eintragen das der  fglrx ATI Treiber geladen wird:

Section \"Device\"
   Identifier  \"ATI Radeon X1950Pro\"
   Driver      \"fglrx\"
   BusID       \"PCI:5:0:0\"
EndSection

Die einzutragende BusID findest du über

lspci

herraus.

fglrxinfo | grep direct

yes

Muß jetzt da stehen dann läuft das auch.

Also wenn du es jetzt nicht hinbekommst  :rolleyes: .

Nobody
Titel: Ubuntu 7.04 - 3D Probleme
Beitrag von: supergamer am 01. Juni 2007, 07:02:58
Normalerweise wurden die Informationen Automatisch in die xorg.conf geschrieben,
sowohl mit dem open Driver als auch dem Probrietary Treiber aber das war unter dem
alten Kernel (Ubuntu 6.06/6.10)

Das ist der Auszug aus der derzeitigen xorg.conf

Zitat
Section \"Monitor\"
   Identifier   \"aticonfig-Monitor[0]\"
   Option      \"VendorName\"   \"ATI Proprietary Driver\"
   Option      \"ModelName\"   \"Generic Autodetecting Monitor\"
   Option      \"DPMS\"   \"true\"
EndSection

Section \"Device\"
   Identifier   \"Generic Video Card\"
   Driver      \"fglrx\"
   Busid      \"PCI:1:0:0\"
EndSection

Section \"Device\"
   Identifier   \"aticonfig-Device[0]\"
   Driver      \"fglrx\"
EndSection


Ich habe den Treiber von der Ati-Seite Installiert. Mit diesem geht zb \"fglrx\" nicht und
folglich auch nicht Beryl (3D Desktop).
Mit dem OpenDriver kann ich Beryl zum laufen bekommen und die Grafikkarte wird auch korrekt erkannt und in die xorg.conf eingefuegt aber dann kann ich keinen 2. Bildschirm mehr nutzen ohne das teil jedesmal zu editieren und 3D Games laufen auch nicht.  :rolleyes:

Section \"Device\"
   Identifier   \"Generic Video Card\" (wenn ich den Namen einfuege Startet X Server                  nicht)
   Driver      \"fglrx\"
   Busid      \"PCI:1:0:0\"
EndSection

Naja danke erstmal fuer deine Hilfe.
Titel: Ubuntu 7.04 - 3D Probleme
Beitrag von: supergamer am 03. Juni 2007, 13:14:12
Nach der Installation der neuen ATI Driver die am 1. June released sind gab es keine besserung. Es scheint mir das viele dieses Problem haben und das es doch nicht ganz so simpel sei. Vieleicht kann trotzdem jemand von euch noch einen kleinen Tipp geben.
Danke im vorraus

fglrxinfo
Zitat
franz@Lappi:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: http://www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

gedit /etc/X11/xorg.conf (ausschnitt)
Zitat
Section \"Monitor\"
   Identifier   \"Generic Monitor\"
   Option       \"DPMS\"
EndSection

Section \"Monitor\"
   Identifier   \"aticonfig-Monitor[0]\"
   Option       \"VendorName\" \"ATI Proprietary Driver\"
   Option       \"ModelName\" \"Generic Autodetecting Monitor\"
   Option       \"DPMS\" \"true\"
EndSection

Section \"Device\"
   Identifier  \"Generic Video Card\"
   Driver      \"fglrx\"
   Option       \"VideoOverlay\" \"on\"
   Option       \"OpenGLOverlay\" \"off\"
   BusID       \"PCI:1:0:0\"
EndSection

Section \"Device\"
   Identifier  \"aticonfig-Device[0]\"
   Driver      \"fglrx\"
EndSection

Section \"Screen\"
   Identifier \"Default Screen\"
   Device     \"Generic Video Card\"
   Monitor    \"Generic Monitor\"
   DefaultDepth     24
   SubSection \"Display\"
      Depth     1
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
   SubSection \"Display\"
      Depth     4
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
   SubSection \"Display\"
      Depth     8
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
   SubSection \"Display\"
      Depth     15
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
   SubSection \"Display\"
      Depth     16
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
   SubSection \"Display\"
      Depth     24
      Modes    \"1280x800\" \"1024x768\" \"800x600\" \"640x480\"
   EndSubSection
EndSection

Section \"Screen\"
   Identifier \"aticonfig-Screen[0]\"
   Device     \"aticonfig-Device[0]\"
   Monitor    \"aticonfig-Monitor[0]\"
   DefaultDepth     24
   SubSection \"Display\"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section \"DRI\"
   Mode         0666
EndSection

Section \"Extensions\"
   Option       \"Composite\" \"Disable\"
EndSection

glxinfo (ausschnitt)
Zitat
franz@Lappi:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Mesa project: http://www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

Der Ati Driver gibt das aus (siehe Screenshot)

Mfg Supergamer