MSI Endanwender-Forum

Rund um MSI Produkte => Notebooks => Thema gestartet von: oringe am 14. Mai 2015, 22:40:51

Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 14. Mai 2015, 22:40:51
Die neusten Treiber beider Grafikkarten sind richtig installiert.
(auch mit den Treiber probiert die zum Notebook dazu waren)
[attach]24489[/attach]


Windows nimmt nicht die GeForce 840M sondern die Intel HD 4600. (Klick auf erweiterte Einstellungen)
[attach]24491[/attach]

Auch gut zu sehen hier, dass das Display an der Intel HD 4600 hängt
[attach]24490[/attach]
Allgemein sieht die Nvidia Systemsteuerung sehr dürftig aus (nicht viel zum Einstellen)
Das liegt aber glaube daran, dass die 840M nicht für die Grafikausgabe zuständig ist.

Natürlich bekommt man auch nette Fehlermeldungen beim starten von Programmen, da der Laptop über die Intel HD 4600 läuft.
[attach]24492[/attach]

Ich habe schon sehr viel probiert:
Energieoptionen
Notebook hängt die ganze Zeit am Stromnetz
in der Nvidia System Steuerung alles auf die 840M gestellt und höchste Performance ect.

Ich möchte dass das Display über die 840M läuft wegen diversen Programmen (siehe Fehlermeldung oben) Browsersgames usw.

Vielleicht weiß ja jemand Rat
Vielen Dank schon mal

System:
Win81 64bit
i5-4210H
8GB RAM
GeForce 840M 2 GB RAM
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: iTzZent am 14. Mai 2015, 22:59:17
Die GT840M wird erst dann aktiviert, wenn sie auch benötigt wird. Die Bildwiedergabe geschieht immer über die Intel GPU, ohne diese funktioniert auch die GT840M nicht. Das Signal der GT840M wird stets über die Intel GPU geschleift. Sobald du ein Spiel oder eine andere grafikintensive Anwendung startest (3DMark z.B.) schaltet sich die GT840M automatisch zu. Browsergames zählen nicht dazu, die laufen auch mit der Intel GPU anstandslos.

btw: installiere mal die Nvidia Treiber neu, da fehlen noch ein paar Optionen in der Nvidia Systemsteuerung.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 14. Mai 2015, 23:05:11
OK danke für deine Antwort.
Kann ich also etwas beruhigt sein.

hm
also kann ich z.B. Nvidia 3D Vision nie benutzen? (siehe Fehlermeldung oben)

Ich habe den Nvidia Treiber schon sehr oft installiert und deinstalliert
Den aller neusten von der Nvidia Homepage dann den Treiber der zum Notebook dazu ist usw.
Es kommen nie mehr Einstellung wie auf dem Sceenshoot zur Nvidia Systemsteuerung dazu.
Das macht mich auch so stutzig.
Ich vermute halt dass es damit zu tun hat dass die Ausgabe nur über die HD4600 läuft und ich somit keine Auflösung, Grafik, Farben ect. in der Nvidia Systemsteuerung einstellen kann.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: iTzZent am 14. Mai 2015, 23:59:14
So sehen die Nvidia Einstellungen bei mir aus:

[attach]24493[/attach]

auch mein Gerät nutzt die Intel GPU für die Bildwiedergabe.

Verwende bitte die folgendenen Treiber:
Intel GPU: http://download.msi.com/nb_drivers/vga/vga_intel_10.18.10.3496_0x98020f83_w818764.zip
Nvidia GPU: http://download.msi.com/nb_drivers/vga/vga_nvidia_332.70_0x95357da4_w818764.zip

Merke: immer zuerst den Intel Treiber installieren. Als aller ersten Treiber sollte man auch stets den Intel Chipsatz Treiber installieren: http://download.msi.com/nb_drivers//cs/chipset_intel_9.4.0.1023_0x30c0e0a8_818700.zip

Danach rebooten und die Nvidia Systemsteuerung überprüfen. Wenn nun die Optionen alle da sind, kannst du gerne den neusten Nvidia Treiber verwenden.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 15. Mai 2015, 17:12:35
Ich habe eine Windows Neuinstallation vorgenommen und die von von dir verlinkten Treiber in deiner Reihenfolge installiert.
Das Ergebnis ist das Selbe wie oben beschrieben  :-(

Was mich auch stutzig macht ist dass nach der Installation von den Nvidia Treiber keine Meldung zum Neustarten des Systems kommt (was eigentlich nach der Installation von Grafiktreibern immer kommt).

In der Nvidia Systemsteuerung fehlen immer noch sehr viele Einstellungen (wie oben auf meinem Screenshot).

Was mich sehr interessieren würde wäre wenn du mal:

Rechtsklick auf Desktop
Bildschirmauflösung
dann auf erweiterte Einstellungen klickst
ob sich dann in dem sich öffnenden Fenster deine Intel HD oder deine GeForce 870M angezeigt wird.
[attach]24495[/attach]

Du hast mir ein Screenshot von der Nvidia Systemsteuerung gezeigt.
Ich würde gern mal die Einstellung eins tiefer bei dir sehen (Surround, PhysX konfigurieren).

Danke schonmal
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: iTzZent am 15. Mai 2015, 17:27:47
[attach]24496[/attach]

Und bei deinem Screenshoot, da wird bei mir auch die HD4600 angezeigt, was auch logisch ist, da die Nvidia Karte nunmal keinen Bildausgang hat.

Warum bei dir aber die ganzen Einstellungen fehlen wundert mich ein wenig. Hast du bei der Treiberneuinstallation den auch den den Hacken bei \"Neuinstallation vornehmen\" gesetzt ? Wenn nicht, mache dies bitte. Dafür musst du die Benutzerdefinierte Installationsroutine wählen. Ein Reboot ist beim Grafikkarte nicht immer von Nöten, deswegen wird das Display wärend der Installation kurz schwarz.

[attach]24497[/attach]
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 15. Mai 2015, 19:09:58
Ich habe den Hacken bei \"Neuinstallation vornehmen\" gesetzt. Hat nichts gebracht.

Wie gesagt hatte ich auch vorher die Windows System Partition formatiert und Windows frisch installiert.
Dann zuerst Chipset, dann die Intel Grafikkarte dann die GeForce (alle die von die verlinkten Treiben).
Immer mit selben Ergebnis.

Ich werde mal ein paar Spiele installieren und schauen wie die Performance so ingame ist.
Werde das Notebook aber wahrscheinlich zurück schicken.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: rysalf am 15. Mai 2015, 19:11:41
Hi, installiere dir GPU-Z und unten hast die Auswahl zwischen Intel und nvidia,
wenn so ist ist alles in ordnung :thumbup:
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 15. Mai 2015, 21:34:43
Ja, bei mir werden bei GPU-Z auch beide Grafikkarten angezeigt wie bei dir.

Aber woher weiß ich zu 100% dass das jeweilige Spiel dann auch die GeForce nutzt und nicht nur die HD 4600?
Schon allein im Windows Modus, der Internetbrowser z.B. der greift ja auch auf die Grafikeinheit zu
z. B. bei aufwendigen  Browsersgames ect.

Ich habe irgendwie das Gefühl dass mein Notebook die GeForce überhaupt nicht nutzt.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: iTzZent am 15. Mai 2015, 22:09:22
Bei der GT Serie verändert sich die Farbe des Powerbuttons bei den unterschiedlichen Grafikkarten. Ich weiss nun nicht, ob es bei der GP Serie auch so ist...  Bei der GT Serie steht weiss für Intel und Orange für Nvidia. Für Browsergames reicht die Leistung der HD4600 aber locker aus, da wird die Leistung der GT840M nicht benötigt. Nvidia´s Optimus funktioniert eigentlich ganz gut, sobald die Leistung nicht mehr ausreichen sollte, schaltet sich die dedizierte GPU ein und übernimmt die Berechnungen. Die Bilderwiedergabe geschieht aber nach wie vor über den Ausgang der Intel GPU. Wenn irgend eine Anwendung mal zu schlecht laufen sollte, kannst du sie unter \"3D Einstellungen verwalten\" hinzufügen und dort direkt die Nvidia GPU zuteilen.

Und erwarte keine HighEnd Leistung. Die GT840M ist zwar schneller wie die HD4600, aber ein Leistungswunder ist sie nicht. Mal ein kleines Beispiel... meine GTX870M kommt auf ca. 8000pt im 3DMark11, die GT840M auf ca. 2300pt, die HD4600 auf ca. 1000. Ich kann mit der GTX870M eigentlich alle aktuellen Spiele gerade so in FullHD mit hohen - maximalen Details geniessen. Wenn bei dir also ein Spiel ruckelt, kann es auch einfach an der doch recht langsamen GT840M liegen, es ist halt keine Gaming Grafikkarte. Sie ist aber eine sehr gute Karte in Sachen Preis/Leistung.

Beim GT72 sowie beim GT80 gibt es z.B. kein Optimus, da muss man zum Wechseln der GPU´s stets neu starten. Nachdem die Intel GPU gewählt wurde, schaltet sich denn die Nvidia komplett inkl Lüfter ab.
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: oringe am 16. Mai 2015, 21:46:48
Vielen Dank für deine Info.

Bei der GP Serie ist das genauso. Habe gleich im Handbuch nachgeschaut und auch mal ein Spiel installiert.
Und tatsächlich schaltet die Power LED von blau (Intel HD) auf gelb (840M)

Da bin jetzt beruhigt. Werde das Notebook also behalten.

Ich habe das Notebook nur um einfache Spiele zu spielen (Civ5, Dota2, WoW) auf guten bzw. hohen Grafikeistellungen, also nichts mit Sehr Hoch oder Ultra (dafür habe ich mein PC  :thumbsup: )
Titel: GP70 2PE Windows 8.1 benutzt falsche Grafikkarte
Beitrag von: iTzZent am 16. Mai 2015, 21:54:46
Na wunderbar, dann ist ja alles i.O.  :thumbup:

Dann wünsche ich weiterhin viel Spass mit dem Gerät !  :thumbsup: