MSI Endanwender-Forum

Rund um MSI Produkte => Rund um BIOS, VBIOS und EFI => EFI-Sektion => Thema gestartet von: Noeliel am 06. Januar 2014, 21:01:57

Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: Noeliel am 06. Januar 2014, 21:01:57
Hallo liebe Community!

Ich bin verzweifelt am versuchen, das BIOS meines Z87-G43 wieder auf die ursprüngliche Version zurückzusetzen. Aber erst mal der Reihe nach:
Mein Main-OS ist Windows 7.
Gestern habe ich über das MSI Forum HQ USB flashing tool das BIOS meines Mobos von Version 1.4 (mit der ich es bekommen habe und mit der es wie am Schnürchen lief, das allerdings den Boot von OS X Mavericks verhinderte) auf eine mittels PMPatch (ist hoffentlich bekannt?) gemoddete / gepatchte Version 1.6 upgedatet, um mir Mavericks auf eine 2. HDD spielen zu können.
Zunächst lief dies auch. Nach ca. einer Stunde fiel mir dann auf, dass im Click BIOS 4 in der Liste der Bootreihenfolge statt den eigentlichen Namen der einzelnen Geräte/Laufwerke auf einmal nurnoch \"???\" stand.
Ist ein Einzelfall, dachte ich mir, und habs erst mal ignoriert. Nach mehreren Neustarts des PCs begann dann das BIOS / Board plötzlich, zu spinnen.
Direkt nach Betätigen des Power-Schalters erscheinen die Debug-Codes in der unteren rechten Bildschirm-Ecke. Bei \"A2\" blieb es jedes mal hängen. Ich habe bereits einige Threads in diesem Forum gelesen, in denen Leute ein ähnliches Problem schilderten. Grundsätzlich werden bei A2 SATA/PCI?-Anschlüsse bzw. über dieselben angeschlossene Geräte gecheckt. In den Threads hieß es, eine defekte Boot-Festplatte könnte das Problem sein. Also Computer aufgeschraubt, meine SSD mit Win7 und meine HDD mit Mac OS X raus, um sicherzugehen, dass diese beiden Laufwerke kein Aufhängen des BIOS mehr hervorrufen können. Gleiches Ergebnis, A2 und nichts geht mehr.
Anmerkung: Nach dem BIOS-Flash habe ich bereits ein dutzend mal über den Jumper ein CMOS-Reset ausgeführt. Dieses scheint auch zu klappen, denn die Meldung eines erfolgreichen Reset wird in einem solchen Fall nach A2 angezeigt, drücke ich dann jedoch F1 fürs BIOS oder F2, um mit dem Booten fortzufahren, hängt es wieder.
Jedenfalls gestern dann plötzlich das Wunder - es ging wieder. Zwar immernoch \"???\" in der Boot-Priority-Liste (während bei F11 die Namen alle stimmen), aber ansonsten schien es zu laufen. Zwischendrin gab es immer mal wieder Aufhänger, die allerdings durch einen Neustart (evtl. mit dem für den Flash genutzten USB-Stick angeschlossen) behoben werden konnten (Anmerkung: dabei wurde nicht erneut geflasht, weshalb ich mich auch gewundert habe, wieso es mit USB häufiger zu laufen schien als ohne).
Jedenfalls heute dann erneut das Problem, mit dem Unterschied, dass auch der USB nicht mehr zu helfen scheint. Hängt bei A2 (falls ich während dem Laden ENTF drücke, steht unten links noch Entering setup...), dann ist Schluss.

Falls es hilft: nach dem Flashen / Update erschien nach den Debug-Codes zusätzlich eine MSI-Grafik, welche bei der vorherigen Version 1.4 noch nicht da war. Ich vermute, er hängt genau an / vor dieser Grafik.
Außerdem habe ich noch sämtliche zuvor gesicherte BIOS-Files verfügbar - zudem das vom zum Flashen genutze Tool erstellte Backup.
Leider scheint mein Board keinen 2. BIOS-Chip zu haben, und da ich nicht zum Punkt der Bootdevice-Auswahl komme (mit anderen Worten: F11 hilft nicht), weiß ich gerade wirklich nicht, was ich tun soll.

Ich würde mich sehr über mögliche Lösungen / Anleitungen freuen!
MfG, Noeliel

*Edit: Kann gut sein, dass ich mit dem Thread hier eine Kategorie zu tief gerutscht bin. Im Fall bitte verschieben!
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: HKRUMB am 06. Januar 2014, 21:12:23
mit fpt(richtige Version ) das gemoddete BIOS +ME Updaten , könnte dir eventuell helfen :thumb
...mflash mit ME Update würde ich nur bei einem nichtgepatchten BIOS benutzen;)
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: der Notnagel am 06. Januar 2014, 21:38:12
du müßest dort zur 9 greifen: FPT das Intel Flash Programming Tool (http://\'http://msi-forum.de/index.php?page=Thread&postID=817509#post817509\')
Am besten, die aktuellste. Bitte mit bootbaren USB2.0-Stick versuchen. Die Befehlszeile eventuell in eine Autoexec.bat schreiben: FPT -f Bios -savemac
Bios steht für dein BIOS-File.

Kannst auch mal hier reinlesen: Mein UEFI ist \"zerschossen\", was kann ich noch tun? (http://\'http://msi-forum.de/index.php?page=Thread&threadID=105186\')
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: Noeliel am 06. Januar 2014, 21:53:53
Zitat von: \'der Notnagel\',\'index.php?page=Thread&postID=825785#post825785\'
du müßest dort zur 9 greifen: FPT das Intel Flash Programming Tool (http://\'http://msi-forum.de/index.php?page=Thread&postID=817509#post817509\')
Am besten, die aktuellste. Bitte mit bootbaren USB2.0-Stick versuchen. Die Befehlszeile eventuell in eine Autoexec.bat schreiben: FPT -f Bios -savemac
Bios steht für dein BIOS-File.

Kannst auch mal hier reinlesen: Mein UEFI ist \"zerschossen\", was kann ich noch tun? (http://\'http://msi-forum.de/index.php?page=Thread&threadID=105186\')
Jop, dankeschön =)
Bin grad am Vorbereiten des USB-Sticks.
Ich geb dann nochmal Rückmeldung.

MfG, Noeliel
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: der Notnagel am 06. Januar 2014, 22:00:19
ich drück dir die Daumen.
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: Noeliel am 06. Januar 2014, 22:30:34
Also, ich hab den USB-Stick jetzt versucht.
Hab zur Sicherheit auch alle anderen Laufwerke nochmal entfernt (SSD, HDD und BluRay-Laufwerk) und einen weiteren CMOS-Reset durchgeführt. Nach dem CMOS-Reset kommt wie immer die Meldung, dass die Einstellungen zurückgesetzt wurden, gefolgt von einer Liste der erkannten Geräte. In dieser Liste ist mein USB-Stick auf Platz 1, leider bootet er nicht (BIOS hängt sich wieder auf).
Nach einem Neustart hängt das BIOS jetzt bei 99 (was am Fehlen des BluRay-Laufwerks liegt, da es wieder bei A2 hängt, wenn ich dieses wieder reinhänge).

Irgendwelche Tipps?

*EDIT: Mir ist noch was eingefallen:
Als ich das letzte mal in der Auswahl des Bootlaufwerks war (F11), hab ich beim wählen des Laufwerks möglicherweise Enter und Backspace zusammen gedrückt (unsauber^^). Als Ergebnis landete ich im BIOS, als ich ESC geklickt hab und Discard Changes bestätigt habe, hat mich das Board direkt wieder ins BIOS geschmissen, und das ging immer wieder so. Hab dann via Power-Schalter resettet, und seitdem hab ichs noch nicht ins Bootmenü geschafft.
Titel: MSI Z87-G43 | BIOS hängt beim booten (nach flash?)
Beitrag von: Noeliel am 07. Januar 2014, 18:13:27
Melde mich nochmal.
Nach Entfernen sämtlicher zusätzlicher USB-Anschlüsse vom Mainboard, einzig allein einem bootbaren USB-Stick mit FPT-Tool drauf (keine Tastatur angeschlossen) und einem weiteren CMOS-Reset habe ich es letztendlich geschafft, die gepatchte 1.6 problemlos zum laufen zu bekommen. Dazu habe ich nach dem CMOS-Reset bei der Meldung des erfolgten Resets die Tastatur angeschlossen und F2 gedrückt (Continue) - dann liefs =)

Herzlichen Dank nochmal euch beiden :party :thumbsup: