MSI Endanwender-Forum

Allgemeines Forum => Rund um Software => Linux & Co => Thema gestartet von: sakamoto am 27. Dezember 2008, 19:54:39

Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: sakamoto am 27. Dezember 2008, 19:54:39
hallö,

wenn ich die kopfhörer in der kopfhörerbuchse einstecke, schalten sich die lausprecher nicht aus.

system: ex600 (http://www.msi-technology.de/index.php?func=downloaddetail&type=driver&maincat_no=135&prod_no=1200)

root@shiva:~# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff8000 irq 21
root@shiva:~# head -n 1 /proc/asound/card0/codec*
==> /proc/asound/card0/codec#0 <==
Codec: Realtek ALC888

==> /proc/asound/card0/codec#1 <==
Codec: LSI ID 1040

root@shiva:~# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

diese anleitung (http://wiki.ubuntuusers.de/Soundkarten_installieren/HDA) habe ich auch befolgt, ohne erfolg!



woran kann das liegen?

danke im voraus
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: REINERV am 28. Dezember 2008, 01:55:36
Guck doch mal HIER (http://www.ubuntu-forum.de/artikel/40552/kopfh%C3%B6rerausgang-ohne-funktion.html)  ;)
Könnte bei Dir auch zutreffen, oder?

Greetz
REINERV
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: sakamoto am 28. Dezember 2008, 23:35:44
zitat:

Diese jack einstellung \"analog/digital Jack\" war mein Problem, ich hatte nur im Subwoofer und in der centralbox, Radioähnlichen sound mit rauschen.
Das war der digitalsound, Häckchen raus gings wieder auch im Kopfhörer *g

aber vorher erstmal Packete und so weiter installiert, hm das man sowas nicht gleich findet....
----------------------------------------------------------------------------------------------------------

hallo,

diese beschreibung ist so wage, dass ich damit nichts mit anfangen kann.
interissant wäre zu wissen welche packete er noch zusätzlich installiert hat.

gruß
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: REINERV am 29. Dezember 2008, 00:19:02
Da geht es wohl um die Pakete welche mit dem \"JACK\"-SoundServer zu tun haben.
Ob Du \"JACK\" benutzt, weiß ich ja nun leider nicht ...  :rolleyes:

Ich benutze das jedenfalls nicht ... daher kann ich da nicht so schlau mitreden - zumal ich mit UBUNTU unter GNOME unterwegs bin und bisher wenig bis gar keine Probleme mit dem Sound hatte.

Aber Du kannst Dich ja mal in der verlinkten Community einklinken und nachfragen, was denn da nun für Pakete installiert wurden  ;) :D


Greetz
REINERV
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: sakamoto am 29. Dezember 2008, 01:44:33
soweit ich bis jetzt mitbekommen habe macht intel ein geheimnis über den chipaufbau.

die verlinkte gemeinde kenne ich bereits, ich dachte mir die msi leute sind etwas versierter was msi-hardware angeht.

auf jeden fall, thx nochmal
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: Jack am 29. Dezember 2008, 13:23:25
Die Stummschaltung (automatische Anschlusserkennung/Automatic Jack Detection) ist softwaregesteuert und würde unter Windows über den Realtek HD Audio ein- oder ausgeschaltet. Das ist sozusagen keine Hardwarefrage, auf die man eine betriebssystem- bzw. treiberunabhängige Antwort geben kann.
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: sakamoto am 29. Dezember 2008, 20:04:25
juhu ich habs hin bekommen,

also ein kleine tut für ex600  user:

system: kubuntu 8.10| kernel 2.6.27-9 generic | ex600 mit HDA-Intel karte und Realtek ALC888
 codec | ar5007eg wlan karte.

1.  per synaptic-packenverwaltung  linux-backports-modules-2.6.27-9-generic suchen und installieren.

2. es kann sein dass nach der install von backports-modules die wlan karte nicht funktioniert, also die madwifi treiber für atheros ar5007 hier  (http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r3875-20081105.tar.gz) downloaden , entpacken und per \"make\" und \"sudo make install\" installieren.

3. bei \"kde/system/hardware treiber\"/ support for 5xxx series for atheros .... deaktivieren und support for atheros 802.11 ... aktivieren.

4. per su  /etc/modprobe.d/blacklist öffnen und in der letzte zeile blacklist AR242x eintragen.

5. per  su /etc/modprobe.d/alsa-base öffnen und in der letzte zeile options snd-hda-intel model=targa-dig eintragen, evtl als model targa-2ch-dig auswählen.

6. neustarten und bei alle players alsa headphone als ausgabegerät anwählen.

finito.
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: REINERV am 29. Dezember 2008, 23:45:25
Öhm?
TARGA?
 .... tztztz  :rolleyes: :D

Aber fein, dass es geklappt hat ---> GLÜCKWUNSCH!  :thumb


Greetz
REINERV
Titel: ex600 kopfhörer und boxen gleichzeitig??
Beitrag von: sakamoto am 30. Dezember 2008, 00:57:29
jo targa, den laut /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz  stehen die

targa-dig            Targa/MSI          

targa-2ch-dig    Targs/MSI with 2-channel
module  bei ALC883/888 in der Description liste ;)

wenn ich meine kopfhörer nicht zum laufen bekommen hätte, würde linux für mich recht unbauchbar sein.

gruß