Creator Center 2.0.45.0 fehlerhaft, ggf. Speicherleck in MSI.CentralServer
Wir veröffentlichen neue Datenschutzrichtlinien um der europäischen DS-GVO, die ab dem 25.Mai 2018 in Kraft tritt, gerecht zu werden. Die neuen Datenschutzrichtlinien können Einfluss auf die Verwendung Ihrer Daten haben. Durch die weitere Nutzung unsere Webseiten stimmen Sie der Verwendung von Cookies, den neuen Datenschutzrichtlinien und den Geschäftsbedingungen zu.
Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge Bitte loggen sie sich ein oder registrieren sie sich.
Erweiterte Suche  

Autor Thema: Creator Center 2.0.45.0 fehlerhaft, ggf. Speicherleck in MSI.CentralServer  (Gelesen 993 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

DeKla86

  • Jungspund
  • **
  • :
  • Offline Offline
  • Beiträge: 11

Hallo,

nach dem Update des Creator Centers gestern  (Ticket ist erstellt, es kamen nur neue Informationen hinzu und ich kann das Ticket nicht Updaten..)
gibt es Probleme. Ich habe das Problem auch schon im US-Forum gepostet, für die deutschen Anwender wiederhole ich das gern, falls jemand das gleiche Problem haben sollte, damit er nicht so lang suchen muss.
Sobald ich eine Antwort auf mein Ticket habe, teile ich die Infos dem Support ebenfalls mit.

Während des Betriebs und auch beim spielen, gibt es regelmäßige FrameDrops, auch Fenster wie Explorer oder TaskManager ruckeln hin und wieder beim verschieben.

Als Ursache konnte ich den Prozess MSI.CentralServer.exe ausmachen, sobald dieser beendet wird, hört das stottern / ruckeln auf.
Der Prozess genehmigt sich nach dem hochfahren 500 MB RAM und lastet diesen, aufgrund der 32 Bit Beschränkung bei weiterem Arbeiten mit bis zu 4 GB vollständig aus und gibt diesen nicht mehr frei, es scheint sich um ein Speicherleck zu handeln.
Je mehr Aktionen am PC erfolgen, um so schneller steigt die Auslastung.

Wird der Prozess beendet, ist das Problem weg. Der Prozess wird scheinbar nicht selber neu gestartet. Es gibt keine Einträge in den Creator Center Logs oder Hinweise in der Windows-Ereignisanzeige.
Ich kann nicht sagen wofür der Prozess verwendet wird, habe ihn aber als Ursache ausfindig machen können.
Natürlich kann das Dragon Center und das dazugehörige MSI SDK deinstalliert werden, dann ist der Spuk ebenfalls vorbei, sollte aber nicht Sinn der Sache sein.
Gespeichert

DeKla86

  • Jungspund
  • **
  • :
  • Offline Offline
  • Beiträge: 11

Um zu zeigen, wie das ungefähr nach 30 Minuten aussieht..
Der Prozess nutzt eine bestimmte Menge RAM, die plötzlich nicht nachvollziehbar ansteigt, bis die reservierte Größe erreicht ist. Sobald das der Fall ist, steigt der Satz des reservierten Speichers an.
Reserviert sich der Prozess mehr RAM, kommt es zu den FPS-Drops bzw. hängern im System, das lässt sich selbst hier im Forum beim tippen feststellen, da die Eingabe für einen kleinen Moment hängt.
Der Prozess nutzt dann für eine kurze Zeit eine bestimmte Menge RAM, ehe dann der Verbrauch wieder ansteigt, bis der reservierte Satz erreicht wird. Das geht nun so weiter, bis 4 GB erreicht sind. Leider hört das ruckeln dann nicht auf, obwohl der Prozess als 32-bit Anwendung nicht mehr Arbeitsspeicher reservieren kann.

Der Screenshot ist nach einer Uptime von 30 Minuten. Alles was ich in der Zeit gemacht habe, ist das MSI SDK zu installieren, damit das Creator Center läuft, welches dann selbst wiederum die ganzen Anwendungen installiert:

Gaming Gear
True Color
Game Highlights
Graphics Fan Tool
Lan Manager
Mystic Light

aber selbst wenn ich die deinstalliere, bleibt der Prozess weiterhin aktiv, es scheint irgendein Prozess zu sein, der für das Creator Center benötigt wird, auch wenn ich noch nicht herausgefunden habe, was es für Auswirkungen hat, wenn der Prozess beendet wird.

Nachtrag: Okay, ist der Prozess beendet, lässt sich das Creator Center nur sehr widerwillig bedienen (Keine Rückmeldung) und die Funktionalität ist sehr eingeschränkt, Die Option "Monitor" ist überhaupt nicht mehr nutzbar.

Sende ein Log durch ein Tool vom Support zu...es geht voran. Wenn man nur öfter in sein Spam Verzeichnis schauen würde..
« Letzte Änderung: 07. Mai 2020, 07:41:21 von DeKla86 »
Gespeichert

jeanlegi

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 2.627

Wäre super, wenn du uns hier ein bisschen auf dem laufenden hälst zu dem Thema!  :thumbup:
Gespeichert
Cheerio
JP
1. |2. GS63VR 6RF Stealth Pro (014DE)|3. GE73VR 7RF Raider (266DE)

DeKla86

  • Jungspund
  • **
  • :
  • Offline Offline
  • Beiträge: 11

Wäre super, wenn du uns hier ein bisschen auf dem laufenden hälst zu dem Thema!  :thumbup:

Aber gern. Ich habe das meiste jetzt im globalen Forum geschrieben, weil hier keine Rückmeldung kam und wollte hier warten, bis es  wieder läuft..

Ich habe gestern Abend nach Anweisung des Supports über das Diagnosetool GUI und SDK deinstalliert und über den Link der Homepage die Version 2.0.45.0 erneut installiert, mit dem gleichen Effekt.
Der Support bittet um Logs, welche ebenfalls mit dem Diagnosetool erstellt bzw. gesammelt werden (C:\Programdata\MSI\, C:\MSI\, ...Ereignisanzeige und co..)

Ich habe es wohl etwas übertrieben und dem Support gestern Abend bis halb 12 oder so, 4 Mails geschrieben, da sich immer wieder neue Erkenntnisse zeigten.
Der Support hat 3x Log Dateien bekommen. (Übrigens nicht so einfach, wenn im Ordner C:\MSI\.. eine CPU_Dll liegt, die über 1 GB groß ist, weil millionenfach das gleiche drin steht. aber mit letztem Datum März..)

Die Log Dateien haben folgende Status:

1. Logs meines aktuellen Systems, Creator Center 2.0.45.0, SDK 1.0.0.38 mit aktivem Windows Update KB4550945 (Optionales Update)
2. Logs aus meinem Backup vom 27.04. wo noch alles gut lief, welches ich ohne LAN Verbindung wiederhergestellt habe und einem Neustart im Anschluss auf Probe. Creator Center 2.0.44.0, SDK Version unbekannt, KB4550945 nicht installiert.
3. Logs aus dem Backup vom 27.04. nach einem weiteren Neustart und einer LAN-Verbindung. Zuvor habe ich im Creator Center "Always Update" deaktiviert. Dennoch wurde nach Aufbau der LAN-Verbindung ohne dass ich etwas weiteres getan habe, eine Installation durchgeführt (kleines Fenster über der Starleiste, stark minimiert, Überschrift "Install" war lesbar) - Im Anschluss war in der Systemsteuerung unter Programme und Funktionen das SDK 1.0.0.38 zu sehen. KB4550945 nicht installiert. Es ist aber weiterhin das Creator Center 2.0.44.0 !

Zustände der Logs:
1. MSI.CentralServer greift sich nach wenigen Minuten bereits mehrere hundert MB, nach 30-60 Minuten liegt die Auslastung des RAM's bei 2-4 GB und damit beim möglichen maximum - es ruckelt regelmäßig, sobald mehr RAM reserviert wird oder er es versucht, obwohl das maximum erreicht wurde.
2. MSI.CentralServer greift auf 26 MB aktiv zu, 32 MB sind reserviert, selbst nach 20 Minuten geht die Auslastung nur um wenige KB nach oben, reduziert sich aber auch immer mal wieder. Sauberer und mir bisher bekannter Zustand.
3. MSI.CentralServer läuft erst bei 30 MB, nachdem das kleine Install Fenster weg war, war sofort das ruckeln da, leider auch mit Version 2.0.44.0, die RAM-Auslastung geht in wenigen Augenblicken wieder in die hunderte bis tausende MB.

Für mich ergibt das also zusammengefasst:

1. Creator Center 2.0.45.0 ist vermutlich fehlerfrei, da das Problem auch mit 2.0.44.0 auftreten kann, wenn ein aktuelles SDK vorliegt. MSI.CentralServer ist eine kleine Datei, welche die gleiche Größe, das gleiche Erstelldatum und die gleiche Version hat, wie in der vorherigen Version 2.0.44.0
2. Das Windows Update KB4550945 verursacht das Problem nicht.
3. Es scheint das SDK zu sein, welches hier Probleme macht, das SDK spricht entweder den Prozess MSI.CentralServer an oder der Prozess greift auf das SDK zu und liefert werte, mit der MSI.CentralServer nicht umgehen kann.
4. Es gibt keinen Fix, die einzige Lösung ist die Deinstallation des SDK und des Creator Centers, bis eine Lösung vorliegt. Wird der Prozess beendet, welcher das Hängen verursacht, ist eine Nutzung des Creator Centers nicht möglich.

Ich passe den Betreff daher an den aktuellen Status an. Geht leider nicht.

Ich hoffe, dass die Beschreibung einigermaßen verständlich ist. Es tat mir gestern wirklich leid, dass der Support das in 4 Mails als Antwort bekommen musste und ich das nicht einfach zusammengefasst habe. Es ist leider beruflich beinahe ähnlich, immer wenn man denkt, das wars mit Ideen und man möchte das Thema abschließen, kommt noch eine Idee der man nachgehen kann..

Im globalen Forum meldete sich jemand, der ebenfalls Probleme hat, allerdings hat er seit dem Update eher Probleme mit der Beleuchtung.
Man gab mir dort den Hinweis, dass es ein Treiber oder ein Programm sein könnte, das es verursacht und ich könnte es auf einem sauberen neu installierten System versuchen - angesichts dessen, dass es in meinem Backup ohne LAN-Kabel ohne Probleme funktioniert und ein Anschluss des LAN-Kabels ein automatisches Update im Hintergrund auslöst, welches dann das Problem wieder hervorruft, gehe ich aber davon aus, dass eine Neuinstallation nicht helfen wird.

Ich habe zwar noch zwei Fragen für mich, die ich mir nicht erklären kann, aber die haben nichts mit dem Thema zu tun..
(Warum wird eine 1 GB große Textdatei unter C:\MSI\ abgelegt, welche millionenfach das gleiche bis zu einem Datum vor 2 Monaten schreibt, danach wird die Datei nicht mehr angefasst?)
(Warum benötigt das Creator Center laut TaskManager 200 MB Grafikspeicher, wenn es nicht sichtbar ist?)

Vielleicht bekomme ich nächste Woche eine Rückmeldung, dann berichte ich gern weiter. Ich habe mein System erstmal wieder auf den letzten Zustand zurückgesetzt, da ich den Stand vom 27.04. nicht Live verwende und das nur zum Test erfolgte.
Gespeichert

jeanlegi

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 2.627

Ok gut zu wissen!
Ich hatte das Prestige X570 Creator für eine Review und habe dort nichts dergleichen feststellen können, aber das war auch schon letztes Jahr.
Aber wäre echt super uns weiter zu informieren, da wir nicht immer alles mitbekommen.
Neuinistallation unter diesen vorasusetzungen sehe ich auch nicht als Lösung an.
Gespeichert
Cheerio
JP
1. |2. GS63VR 6RF Stealth Pro (014DE)|3. GE73VR 7RF Raider (266DE)

DeKla86

  • Jungspund
  • **
  • :
  • Offline Offline
  • Beiträge: 11

Ich habe aus Jux mal heute einen neuen Test gemacht.
Creator Center 2.0.45.0 - es wird nun ein neues SDK installiert, 1.0.0.39
Das Verhalten ist unverändert. Ich kann das Creator Center als App gänzlich deinstallieren, der Prozess MSI.CentralServer bleibt weiter auf dem System und reserviert immer weiter RAM (selbst mit der RAM bereinigen Funktion im Center wird mehr reserviert, obwohl die aktuelle Nutzung des RAM noch nicht mal an der Grenze liegt.
Vom Support habe ich leider auch noch keine Rückmeldung bekommen, ich schreibe denen aber schonmal den aktuellen Stand, nur für den Fall, dass man auf ein neues SDK hinweisen möchte.
Gespeichert

DeKla86

  • Jungspund
  • **
  • :
  • Offline Offline
  • Beiträge: 11

Habe Info vom Support bekommen.
Es gibt eine neue Version - 2.0.46.0, ich wurde gebeten erst alle Überreste mit dem SupportTool zu deinstallieren, den PC neu zu starten, über den Link das Dragon Center (ja, Dragon Center - hat mich etwas irritiert, da es um das Creator Center ging, ich habe den Link daher etwas angepasst und ja - es gibt auch ein Creator Center 2.0.46.0. Nach erfolgter Installation erneut neu gestartet, das SDK installiert - kein Problem. Habe erneut neu gestartet - kein Problem.
Wenn ich das richtig sehe, steht die Version bereits im Microsoft Store zur Verfügung.

Abschließend sei also gesagt:

SDK 1.0.0.39 + Creator Center 2.0.46.0 funktioniert wieder ohne Probleme, keine Lags, kein überhöhter RAM-Verbrauch mehr, nach 40 Minuten bei 44 MB - alles in Ordnung.

Gibt es irgendwie einen Weg, wie ich das Thema als gelöst markieren kann ?
Gespeichert

jeanlegi

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 2.627

Bietet das Forum leider nicht höchstens, wenn möglich über den Betreff.
Und danke für die Rückmeldung! :)
Gespeichert
Cheerio
JP
1. |2. GS63VR 6RF Stealth Pro (014DE)|3. GE73VR 7RF Raider (266DE)