Wir veröffentlichen neue Datenschutzrichtlinien um der europäischen DS-GVO, die ab dem 25.Mai 2018 in Kraft tritt, gerecht zu werden. Die neuen Datenschutzrichtlinien können Einfluss auf die Verwendung Ihrer Daten haben. Durch die weitere Nutzung unsere Webseiten stimmen Sie der Verwendung von Cookies, den neuen Datenschutzrichtlinien und den Geschäftsbedingungen zu.
Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge Bitte loggen sie sich ein oder registrieren sie sich.
Erweiterte Suche  

Autor Thema: X570 BIOS update breaks cpupower tool  (Gelesen 1077 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
X570 BIOS update breaks cpupower tool
« am: 11. September 2019, 20:35:41 »

Hallo,
ich habe heute auf meinem  MPG X570 GAMING EDGE WIFI ein BIOS update gefahren. Von 7C37v12 auf 7C37v13.

 Seitdem funktioniert unter Linux das cpupower Kommando nicht mehr:

3# cpupower frequency-info                                   
analysiere CPU 0:
  kein oder nicht bestimmbarer cpufreq-Treiber aktiv
  Folgende CPUs laufen mit der gleichen Hardware-Taktfrequenz: Not Available
  Die Taktfrequenz folgender CPUs werden per Software koordiniert: Not Available
  Maximale Dauer eines Taktfrequenzwechsels:  Cannot determine or is not supported.
Not Available
  mögliche Regler: Not Available
  Unable to determine current policy
  current CPU frequency: Unable to call hardware
  current CPU frequency:  Unable to call to kernel
  boost state support:
    Supported: yes
    Active: no


Vorher war das alles kein Problem.

Ist das Problem schon bekannt?
Gespeichert

HKRUMB

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 9.974
    • Wunschliste
Re: X570 BIOS update breaks cpupower tool
« Antwort #1 am: 11. September 2019, 20:40:22 »

... installiere mal das BIOS  1.41 ... ist eine gute Beta ... oder deaktiviere den Core Boost  und den PBO ...  dass sollte dir erst mal helfen  ;-)

ach ja ... CMOS Reset nach Update nicht vergessen ...
https://forum-de.msi.com/index.php/topic,116367.25.html
Gespeichert
MSI MPG X570 Gaming EDGE WiFi / Ryzen 9 3900X @3,8GHz / Corsair H150i Pro / Fractal Design Define R6 Black
2x 16GB G.Skill DDR4-3600MHz CL17 / MSI RTX2070 SUPER Gaming / Corsair Force Series MP600 1TB PCIe4.0 / Corsair RMi 850W

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #2 am: 11. September 2019, 21:07:23 »

Vielen Dank für die Info!
Aber was ist PBO und Core Boost? Und warum muss ich ein CMOS reset machen? Braucht man doch normalerweise nicht.
Gespeichert

HKRUMB

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 9.974
    • Wunschliste
Re: X570 BIOS update breaks cpupower tool
« Antwort #3 am: 11. September 2019, 21:29:13 »

schau im Bios ...
Gespeichert
MSI MPG X570 Gaming EDGE WiFi / Ryzen 9 3900X @3,8GHz / Corsair H150i Pro / Fractal Design Define R6 Black
2x 16GB G.Skill DDR4-3600MHz CL17 / MSI RTX2070 SUPER Gaming / Corsair Force Series MP600 1TB PCIe4.0 / Corsair RMi 850W

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #4 am: 12. September 2019, 07:01:28 »

Ich habe jetzt ein CMOS Reset gemacht, PBO deaktiviert und Core Boost deaktiviert. Aber es hat nichts geholfen.

cpupower kann die frequenz etc. immer noch nicht abfragen. Und zu allem Überfluß hat der PC jetzt an Performance verloren. Mein üblicher darktable benchmark liegt jetzt bei 10,2 Sekunden. Er war Vorher bei 9,8 Sekunde.
Gespeichert

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #5 am: 12. September 2019, 07:15:25 »

EDIT:
Bitte diesen Post ignorieren. lm-sensors funktioniert ok - mit kernel 5.2. Ich hatte hier aber noch kernel 4.19 am Laufen. Und damit funktionieren die sensoren nicht.
Sorry. Ich würde den Post auch löschen. Weiß aber nicht wie.


Und lm-sensors liefertb auch keine Temperaturen mehr:

6# sensors
zenpower-pci-00c3
Adapter: PCI adapter
SVI2_Core:   -43.00 mV
SVI2_SoC:    -43.00 mV
Tdie:        +206.9°C  (high = +70.0°C)
Tctl:        +206.9°C 
SVI2_P_Core: -268.10 mW
SVI2_P_SoC:  -93.05 mW
SVI2_C_Core:   6.24 A 
SVI2_C_SoC:    2.16 A 

iwlwifi-virtual-0
Adapter: Virtual device
temp1:        +38.0°C 


Vorher wurden alle Temperaturen sauber angezeigt. Hier ein alter output von sensors:

14# sensors
k10temp-pci-00c3
Adapter: PCI adapter
Tdie:         +60.5°C  (high = +70.0°C)
Tctl:         +60.5°C 

nct6797-isa-0a20
Adapter: ISA adapter
in0:                     1.22 V  (min =  +0.00 V, max =  +1.74 V)
in1:                     1.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in2:                     3.38 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in3:                     3.28 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in4:                     1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                   144.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                   592.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in7:                     3.36 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in8:                     3.33 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in9:                     1.80 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in10:                    0.00 V  (min =  +0.00 V, max =  +0.00 V)
in11:                  416.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                    1.12 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                  680.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                    1.54 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                     0 RPM  (min =    0 RPM)
fan2:                   610 RPM  (min =    0 RPM)
fan3:                   451 RPM  (min =    0 RPM)
fan4:                   465 RPM  (min =    0 RPM)
fan5:                   438 RPM  (min =    0 RPM)
fan6:                     0 RPM  (min =    0 RPM)
fan7:                     0 RPM  (min =    0 RPM)
SYSTIN:                 +36.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = CPU diode
CPUTIN:                 +39.0°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN0:                +50.5°C  (high = +115.0°C, hyst = +90.0°C)  sensor = thermistor
AUXTIN1:               -128.0°C    sensor = thermistor
AUXTIN2:                +66.0°C    sensor = thermistor
AUXTIN3:                 -2.0°C    sensor = thermistor
SMBUSMASTER 0:          +61.0°C 
PCH_CHIP_CPU_MAX_TEMP:   +0.0°C 
PCH_CHIP_TEMP:           +0.0°C 
PCH_CPU_TEMP:            +0.0°C 
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled


Diese BIOS update scheint die komplette Schnittstelle zu den cpu tools kaputt gemacht zu haben. Kann man eigentlich auch downgraden?
Gespeichert

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #6 am: 12. September 2019, 07:37:44 »

Ich habe jetzt einen BIOS downgrade gemacht. Ich warte mit dem upgrade erstmal. Das scheint mir alles noch nicht Reif genug. Und was mich erstaunt ist, das das in der ganzen beta Phase nicht aufgefallen ist. Das spricht nicht für den QA Prozess.

Gespeichert

homey12

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 2
Re: X570 BIOS update breaks cpupower tool
« Antwort #7 am: 12. September 2019, 12:22:48 »

hallo mbod,

ich bin mit dem bios 7C37v13 auch nicht zufrieden. gibt es eine anleitung wie man die 7C37v11 downgraden kann.
Gespeichert

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #8 am: 12. September 2019, 12:34:46 »

Es gibt meines wissens nach keinen speziellen downgrade prozess. Ich habe einfach die ältere BIOS Version auf den USB stick kopiert und über die M-Flash Funktion im BIOS geflashed. Der selbe Prozess wie beim update. Hat bei mir prima funktioniert.
Gespeichert

homey12

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 2
Re: X570 BIOS update breaks cpupower tool
« Antwort #9 am: 12. September 2019, 13:02:15 »

das werde ich auch mal versuchen. danke
Gespeichert

mbod

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 7
Re: X570 BIOS update breaks cpupower tool
« Antwort #10 am: 20. September 2019, 09:29:15 »

Die neue BIOS version 1.40 hat das gleiche Problem mit dem cpupower tool.
Gespeichert