Wir veröffentlichen neue Datenschutzrichtlinien um der europäischen DS-GVO, die ab dem 25.Mai 2018 in Kraft tritt, gerecht zu werden. Die neuen Datenschutzrichtlinien können Einfluss auf die Verwendung Ihrer Daten haben. Durch die weitere Nutzung unsere Webseiten stimmen Sie der Verwendung von Cookies, den neuen Datenschutzrichtlinien und den Geschäftsbedingungen zu.
Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge Bitte loggen sie sich ein oder registrieren sie sich.
Erweiterte Suche  

Autor Thema: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10  (Gelesen 611 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50

Hallo,

habe hier im Forum fast alles gelesen zum Thema "PCI lock" - meistens hatte es mit BIOS und OC zu tun... Auf mein Problem habe ich leider keine Antwort gefunden!

Ich habe auf dem genannten MB in den letzten Monaten einige Umrüstungen vorgenommen, u. a. eine stärkere CPU, mehr RAM (32 GB), 2 SSDs, neues (stärkeres) Netzteil, größere HDD (2 TB), neues BIOS (Beta-Release März 2018), usw. Auch Win10 Pro (64bit, V. 1809) ist drauf und ich bin eigentlich ganz zufrieden (abgesehen von Bluescreens 1 bis 2 x im Monat).

Gestern habe ich es dann gewagt über die msconfig-Funktion im Win10 den PCI-lock zu aktivieren, weil ich irgendwo gelesen habe der Rechner könnte dadurch schneller werden...

Nach dem Aktivieren von PCI lock habe ich dann den üblichen Neustart des PCs vorgenommen - hat auch geklappt ohne Fehlermeldung (Windows hoch, Autostart-Probramme auch OK), Bildschirmanzeige auch OK! Aber... Ich konnte keine Maus und keine Tastatur mehr bedienen! --> USB-Stecker von Maus/Tastatur aus-/ein-gesteckt --> keine Änderung (dass diese Geräte Strom bekamen habe ich leicht sehen können, denn beide sind beleuchtet)!

Irgendwann Power-Taste gedrückt und PC wurde ganz normal heruntergefahren (habe ich so in den Energieoptionen von Win10 eingestellt).

Danach noch 3 mal probiert normal hochzufahren, wieder alles ganz normal und schneller als vorher - aber wieder keine Maus/Tastatur!

Habs dann aufgegeben und über den abgesicherten Modus von Windows den "PCI lock" wieder de-aktiviert. Jetzt funktioniert wieder alles wie vorher. Allerdings waren die Geschwindigkeitsvorteile mit aktiviertem PCI lock schon wesentlich.

Was kann ich tun (vielleicht eine BIOS-Einstellung oder so?), damit Maus + Tastatur bei aktiviertem PCI lock normal funktioniert?

Danke schonmal vorab!
Gespeichert

HKRUMB

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 9.533
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #1 am: 15. Januar 2019, 11:10:12 »

Zitat
Wird die Funktion "PCI Lock" in Windows 7 aktiviert, weist das Betriebssystem keine Interrupts (IRQ) und Systemressourcen mehr zu, sondern überlässt diese Aufgabe komplett dem BIOS. Das kann zu schnellerem Booten führen, aber auch einen Bluescreen produzieren. So aktivieren Sie "PCI Lock":
  • Geben Sie im Startmenü "msconfig" ein.
  • Klicken Sie mit der rechten Maustaste auf den Suchtreffer und wählen Sie "Als Administrator ausführen".
  • Über "Start | Erweiterte Optionen" schalten Sie den "PCI Lock" ein.
  • Jetzt sollte Ihr PC schneller starten. Erhalten Sie jedoch einen Bluescreen, hilft Ihnen der zweite Absatz weite
  • Quelle : Chip  https://praxistipps.chip.de/systemstart-beschleunigen-mit-pci-lock_27242
da hat das BIOS ein Problem alle Interrupts (IRQ) und Systemressourcen zuzuweisen ...vermute ich mal ;-)

versuch die USB Ports für Mouse und Tastatur  in der Nähe vom Lanport und aktiviere USB legacy support im bios
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #2 am: 15. Januar 2019, 11:22:21 »

WOW - danke für die schnelle Antwort!!! :-)

Werde ich gleich heute Abend ausprobieren, sobald ich Zuhause bin... Melde mich dann wieder mit Ergebnisse! 8-)
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #3 am: 15. Januar 2019, 19:51:04 »

Ich wieder...

Als erstes habe ich USB Ports für Mouse und Tastatur direkt neben dem Lan-Anschluss angeschlossen. Danke für den Tipp!!!

Beim Hochfahren keine Probleme, keine Fehlermeldungen... Im BIOS war bereits Legacy USB Support "enabled" - hab also nichts umgestellt. Nach dem Hochfahren merkte ich jedoch sofort, dass meine Audio-Steuerung teilweise nicht funktionierte... Habe nämlich neben Onboard-Sound noch eine Soundblaster + Audio per HDMI (SmartTV) + Audio per DVI (PC-Monitor). PC-Monitor + SmartTV hängen an eine PCI2.0-Grafikkarte von nVidia. Ich nutze die Onboard-Grafik nicht!

Habe ziemlich schnell im Geräte-Manager von Win10 geschaut und sofort ist mir angezeigt worden (unter Systemgeräte), dass an 3 von 4 High Definition Audio-Controller-Einträge Fehler waren. Bei den ersten 3 Einträge steht unter Gerätestatus: Das Gerät kann nicht gestartet werden. (Code 10) - Nicht ausreichend Systemressourcen, um die API abzuschließen. Beim 4. Eintrag steht ganz normal: Das Gerät funktioniert einwandfrei.

Ich hab mir die 4 Einträge einzeln genauer angesehen - hier die Daten:
1. Eintrag: PCI-Bus 7, Gerät 0, Funktion 0 (Code 10)
2. Eintrag: PCI-Bus 0, Gerät 27, Funktion 0 (Code 10)
3. Eintrag: PCI-Bus 0, Gerät 3, Funktion 0 (Code 10)
4. Eintrag: PCI-Bus 0, Gerät 3, Funktion 0 (einwandfrei)

@HKRUMB hat mit seine Vermutung schon richtig gezielt: "da hat das BIOS ein Problem alle Interrupts (IRQ) und Systemressourcen zuzuweisen ...vermute ich mal"

Ich hatte im BIOS bei PCI zunächst GenX=3 gehabt und jetzt auf "auto" gestellt. Busclock (latendy timer) ist auf Standard 32! Man kann bis max. 248 einstellen... Dann habe ich natürlich HD Audio Controller auch "enabled".

Zu erwähnen ist noch: im BIOS sind bei der USB-Einstellung XHCI- und EHCI-Handoff beides "enabled"... Auch der USB3.0-Controller! Diesen Hinweis schreibe ich, weil bei meinen Tests es irgendwann trotzdem passiert ist, dass Maus + Tastatur wieder ohne Funktion waren (obwohl sie jetzt nah am LAN-Ausgang stecken). Ich mussten den PC 4 x beim Hochfahren abwürgen, damit ich wieder ins BIOS konnte. Habe jetzt bei der letzten Einstellung im BIOS USB legacy von "enabled" auf "auto" gestellt!

Hat jemand ein Rat/Tipp wie man diese PCI-/Systemressourcen-Probleme beheben kann (z.B. latendy timer erhöhen...)? Oder muss ich ganz auf "PCI-Lock" verzichten?

Vorab schon mal danke für Eure Mühe!
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #4 am: 17. Januar 2019, 08:23:23 »


Ich hab mir die 4 Einträge einzeln genauer angesehen - hier die Daten:
1. Eintrag: PCI-Bus 7, Gerät 0, Funktion 0 (Code 10)
2. Eintrag: PCI-Bus 0, Gerät 27, Funktion 0 (Code 10)
3. Eintrag: PCI-Bus 0, Gerät 3, Funktion 0 (Code 10)
4. Eintrag: PCI-Bus 0, Gerät 3, Funktion 0 (einwandfrei)


Sorry, mir ist da ein Fehler passiert beim 4. Eintrag...
Richtig ist: PCI-Bus 1, Gerät 0, Funktion 1 (einwandfrei)

Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #5 am: 17. Januar 2019, 09:34:23 »


Ich hab mir die 4 Einträge einzeln genauer angesehen - hier die Daten:
1. Eintrag: PCI-Bus 7, Gerät 0, Funktion 0 (Code 10)
2. Eintrag: PCI-Bus 0, Gerät 27, Funktion 0 (Code 10)
3. Eintrag: PCI-Bus 0, Gerät 3, Funktion 0 (Code 10)
4. Eintrag: PCI-Bus 1, Gerät 0, Funktion 1 (einwandfrei)

So, jetzt konnte ich auch die Geräte identifizieren...

1. Eintrag: HD-Audio-Gerät Multimedia Creative Labs (Fehler-Code 10)
2. Eintrag: HD-Audio-Gerät Multimedia Intel Corporation (Fehler-Code 10)
3. Eintrag: HD-Audio-Gerät Multimedia Intel Corporation (Fehler-Code 10)
4. Eintrag: HD-Audio-Gerät Multimedia NVIDIA (einwandfrei/kein Fehler)

Bei 4. (NVIDIA) ist es die GeForce GTX 1060 an der ich PC-Monitor + SmartTV hängen habe (diese hat keine Probleme mit PCI lock...).

Aber bei 1. ist es die alte Sound Blaster X-Fi Xtreme Audio-Karte, 2. + 3. ist es der Onboard-Sound (von Intel?/Realtek?)... --> "Das Gerät kann nicht gestartet werden. (Code 10) - Nicht ausreichend Systemressourcen, um die API abzuschließen"

===> Kann hier der PCI Latency Timer weiter helfen? Wen ja, welchen Wert?
Gespeichert

HKRUMB

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 9.533
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #6 am: 17. Januar 2019, 10:38:02 »

Zitat
"Das Gerät kann nicht gestartet werden. (Code 10) - Nicht ausreichend Systemressourcen, um die API abzuschließen"
das BIOS teilt die Ressourcen nicht ein , so sagts Windows  :-)

den PCI Latency Timer zu erhöhen machts nur instabiler...


Zitat
Die Funktion legt den Zeitraum (in Taktzyklen) fest, in dem eine PCI-Karte den Bus noch beanspruchen darf wenn ein anderes Gerät eine Anfrage auf Verwendung des Busses "angemeldet" hat.
 Das ist keine Funktion die was mit Performance zu tun hat sondern nur ein Kompatibilitätswert um Probleme zu beseitigen die auf Latenzen beruhen (manche TV-Karten brauchen höhere Werte).

Quelle PC Games Hardware
http://extreme.pcgameshardware.de/mainboards-und-arbeitsspeicher/378683-frage-zu-pci-latency-timer.html
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #7 am: 18. Januar 2019, 13:02:04 »


Zitat
Quelle PC Games Hardware
http://extreme.pcgameshardware.de/mainboards-und-arbeitsspeicher/378683-frage-zu-pci-latency-timer.html

@HKRUMB Danke für die Hinweise - habe jedoch auch diesen Beitrag auf derselben Website gelesen:

http://extreme.pcgameshardware.de/mainboards-und-arbeitsspeicher/405982-pci-latency-timer.html
Zitat
Ende vom Lied: Herumdoktern musst du an der Einstellung nur, wenn die 2 oder mehr PCI (*nicht Express*) Karten in deinem PC stecken hast.

Da ich mir nicht sicher war, ob ich 2 PCI-Geräte habe (oder mehr...), habe ich mir die Mühe gemacht und im BIOS ein wenig herumgespielt...

Von Latency Timer 32 (Standard) --> 96 --> 160 --> 224 --> 248 gestellt und nach jeder Einstellung System neu gebootet (die Zwischenwerte habe ich ausgelassen). Ich wollte einfach wissen, ob mit einen höheren Werte der PCI-Lock weniger Probleme macht und meine 3 Geräte mit Code 10 doch noch aktiviert werden...

Ergebnis: keine Änderung! Die 3 Geräte werden nicht aktiviert (weiterhin Code 10). ==> Also Timer wieder auf Standardwert 32 gestellt.

Aber ein anderes Problem konnte ich lösen (ja, ohne es zu wollen habe ich in diesem Thread gleich 2 angesprochen - das 1. war nämlich "USB-Probleme beim Aktivieren von PCI lock in Win10"). Beim Durchsuchen im BIOS ob irgendein Parameter zur Lösung des PCI-Lock-Problems führen könnte, bin ich auch auf das MSI Fast-Boot (unter Option Windows 8.1 Konfiguration) gestoßen... In der Beschreibung steht nämlich, dass "beim Booten alle Geräte ausgeschaltet bleiben (oder so ähnlich). Das ist auch der Grund, warum ich beim Booten immer nur mein System (C) - Laufwerk gesehen habe, obwohl ich noch 2 weitere + DVD-Laufwerk habe.

Zunächst habe ich "MSI Fast-Boot" UND auch die 2. Option "Win8.1 Fastboot" deaktiviert --> keine Probleme mehr mit Maus + Tastatur... Auch bei eingeschaltetem PCI-Lock! Danach "Win8.1 Fastboot" aktiviert damit es doch vielleicht ein wenig schneller geht als ganz ohne Fastboot --> auf jeden Fall macht auch hier der USB immer noch keine Probleme! Ob es schneller ist beim Booten, kann ich momentan noch nicht sagen... In der USB-Konfiguration habe ich weiterhin XHCI aktiv, EHCI inaktiv und Legacy auf "Auto"!

Zitat
das BIOS teilt die Ressourcen nicht ein , so sagts Windows 

So ist es...

Mich stellt sich nur die Frage, ob man das BIOS dazu bringen kann es doch zu tun!? Und wenn ja, wie? z.B. mit andere CPU-/RAM-Einstellungen im BIOS, usw.

Hab bei meiner Suche zumindest die neuesten Treiber für Realtek HD Audio gefunden + installiert in der Hoffnung, dass es vielleicht zumindest für dieses Gerät dann das PCI-Lock-Problem gelöst wäre... Leider nein! Hab zumindest jetzt den neuesten Audio-Manager bekommen.

@HKRUMB Ist es besser in einen neuen Thread zu posten?
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #8 am: 18. Januar 2019, 13:14:13 »

Sorry, habe irgendwie Probleme bei der Formatierung... :-(
Gespeichert

HKRUMB

  • Ehrenmitglied
  • ***
  • :
  • Offline Offline
  • Beiträge: 9.533
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #9 am: 25. Januar 2019, 15:23:07 »

die Forensoftware ist ein Grauen  ;-) ... du hast Fastboot aktiviert und nun startet dein Rechner viel schneller ohned PC I Lock ?

Startzeit ist dabei im Taskmanager die BIOS Bootzeit
Gespeichert

Inetdude

  • Eroberer
  • ****
  • :
  • Offline Offline
  • Beiträge: 50
Re: B85M-E45 --> USB-Probleme beim Aktivieren von PCI lock in Win10
« Antwort #10 am: 25. Januar 2019, 17:50:37 »

@HKRUMB:
Danke sehr für diesen Hinweis... Mir war noch nie aufgefallen, dass die BIOS Bootzeit im Taskmanager angezeigt wird!!! :-)

Jetziger Status:
--> Ich habe im BIOS alles wieder rückgängig gemacht! Auch MSI Fastboot ist wieder aktiv und somit bekomme ich beim Booten nur das C-Laufwerk angezeigt und alle andere SATA-/USB-Geräte nicht! Die werden dann wohl mit Windows aktiviert, nehme ich an.
--> Und im msconfig PCI Lock auch wieder deaktiviert (damit ich an meinem PC "normal arbeiten" kann...)

Also, alles auf Anfang! Hab keine Lösung gefunden wie man bei aktivem PCI Lock die 3 Audio-Geräte aktivieren kann...

Sonst jemand mit eine (oder mehrere) Idee(n)? ;-)
Gespeichert