Raid-0 Einstellungen gelöscht..
Wir veröffentlichen neue Datenschutzrichtlinien um der europäischen DS-GVO, die ab dem 25.Mai 2018 in Kraft tritt, gerecht zu werden. Die neuen Datenschutzrichtlinien können Einfluss auf die Verwendung Ihrer Daten haben. Durch die weitere Nutzung unsere Webseiten stimmen Sie der Verwendung von Cookies, den neuen Datenschutzrichtlinien und den Geschäftsbedingungen zu.
Bitte loggen sie sich ein oder registrieren sie sich.

Einloggen mit Benutzername, Passwort und Sitzungslänge Bitte loggen sie sich ein oder registrieren sie sich.
Erweiterte Suche  

Autor Thema: Raid-0 Einstellungen gelöscht..  (Gelesen 1123 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

El_Stevo

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 5
Raid-0 Einstellungen gelöscht..
« am: 22. Januar 2016, 16:51:25 »

Vorgeschichte ...
Ich wollte meine Daten vom NAS-Server auf ein Motherboard Raid-5 überspielen.
Dafür hatte ich ein Raid-0 auf meinem Rechner erstellt und die Daten überspielt.

Die Festplatten von meinem NAS-Server ausgebaut und in meinen Rechner eingebaut. Bei dem versuch ein weiteres Raid zu erstellen wurden nicht alle Festplatten erkannt (jetzt weiß ich das nicht alle Sata-Anschlüsse Raid fähig sind) und eine Festplatte zeigte SMART-Event an (Hab mich blöder weise nicht informiert).

In der Annahme das noch Raid-5 Einstellungen vom NAS-Server vorhanden sind, die mir Probleme bereiten, habe ich im RAID-Menü "Reset Disks to Non-Raid" ausgewählt und bestätigt.

Jetzt habe ich mir die Raid-0 Einstellungen zerschossen und ich komme nicht mehr an die Daten ran.

Gibt es ein Programm oder Vorgehensweise wie ich mir die Daten retten kann?

Habe ein X99A XPOWER AC Mainboard 
Gespeichert

Edisoft

  • Forumtreffen
  • *
  • :
  • Offline Offline
  • Beiträge: 5.115
Re: Raid-0 Einstellungen gelöscht..
« Antwort #1 am: 22. Januar 2016, 19:25:45 »

Hallo,

Du mußt wissen das ein NAS ein anderes Datenträger-Format benutzt, meißtens ein EXT was von Linux kommt.
Zudem kommt, gerade bei einem Raid-5, das eigentlich keine Möglichkeit gibt dieses Raid in JBOD aufzulösen, da im Raid-5 die Daten auf allne Festplatten ungleichmäßig verteilt sind.
Ich hoffe Du hattest ein Backup...

Welches NAS hast Du ?
Gespeichert

El_Stevo

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 5
Re: Raid-0 Einstellungen gelöscht..
« Antwort #2 am: 22. Januar 2016, 20:50:39 »

Das Raid das ich herstellen möchte ist das Raid-0 auf meinem Motherboard. Das hab ich natürlich dort auch erstellt.
Das Raid besteht aus 2x2TB auf die ich die Daten von meinem NAS kopiert habe.

Die 4 Festplatten von meinem NAS hab ich inzwischen auch schon mehrere male in Raid-0 umgewandelt, Daten-Müll drauf geschrieben und wieder aufgelöst, als Tests um verschiedene Wege aus zu probieren.

Bis Jetzt bin ich so weit, dass wenn ich die 2 Festplatten wieder in ein Raid-0 umwandle, und ich sie wieder ganz normal formatiere, als ob ich ein komplett neues Raid-0 erstelle dann könnte ich mit "Pririform Recuva" einen Teil meiner Daten retten.

Edit: Das Raid-0 hatte ich nur erstellt um die Daten von meinem NAS zwischen zu lagern. 
Dann wollte ich mit den 4 Festplatten aus dem NAS ein Raid-5 auf meinem Rechner erstellen, die Daten vom Raid-0 aufs Raid-5 überspielen und falls möglich das Raid-5 mit dem 2 Festplatten vom Raid-0 erweitern.
« Letzte Änderung: 22. Januar 2016, 20:58:14 von El_Stevo »
Gespeichert

Edisoft

  • Forumtreffen
  • *
  • :
  • Offline Offline
  • Beiträge: 5.115
Re: Raid-0 Einstellungen gelöscht..
« Antwort #3 am: 22. Januar 2016, 22:21:09 »

Puh,

so richtig durchsehen tu ich da noch nicht.
Schön aber das Du vorher die Daten vom NAS auf das Raid-0 im PC gesichert hast.
Achso, habe eben nochmal #1 durchgelesen: Durch die ganze Rumspielerei hast Du Dir nun auch noch die Daten vom Raid-0 aufm PC
zerknallt, welche ja das Backup des NAS enthielten.

Wen ich das nun richtig zusammen getragen habe folgendes:
Auf die Daten vom ehemaligen Raid-5 vom NAS kommst du nicht ran.
und das Backuop aufm Raid-0 im PC ist auch zerschoßen.

Wenn dem so ist, würde ich als erstes versuchen die ehemaligen platten vom Raid-5 NAS wieder in den NAS einzubauen
und dort auf ein Recovery zu hoffen. Das heißt im besten Fall stellt das NAS den ursprünglichen Zustand wieder her.
Welches NAS hast Du? Die Frage wurde noch nicht beantwortet !
Denn in speziellen Foren des jeweiligen Herstellers kannst Du weitaus kompetetentere Antworten und Lösungansätze erwarten, wie hier in einem reinen
PC-Forum.
Zum Beipsiel, wenn es um Zyxel geht hier (dort bin ich auch unterwges): http://www.zyxelforum.de/

Die andere grundsätzliche Frage aber:
was Du mit den anderen 4 Platten aus dem NAS Raid-5 genau vor hattest ?
Willst Du dein NAS aufgeben und dieses Raid-5 im PC weiter benutzen ?
« Letzte Änderung: 22. Januar 2016, 22:28:50 von Edisoft »
Gespeichert

El_Stevo

  • Grünschnabel
  • *
  • :
  • Offline Offline
  • Beiträge: 5
Re: Raid-0 Einstellungen gelöscht..
« Antwort #4 am: 26. Januar 2016, 07:22:34 »

So erfreuliche Nachricht für die, die mit gefiebert haben und vielleicht das gleich Problem haben...
Die Lösung heißt "File Scavenger" und kostet leider ca 50€, da die Testversion Dateien nur bis 64kB herstellt :-(
Aber ich sag mal so ... wer suchet der findet ;-)

Das Scannen die 2x2TB Raid 0 hat ca 10 Stunden gedauert wobei er schon am Anfang alle Daten gefunden hatte; hab es nur sicherheitshalber Durchlaufen lassen. Das wiederherstellen waren dann ca 35 Stunden.

Bis dann...
Gespeichert